Java Mailing List Archive

http://www.java2.5341.com/

Home » Maven Announcements »

[ANN] Maven Dependency Plugin 2.5.1 Released

Olivier Lamy

2012-08-27


Author LoginPost Reply
Hi,
The Apache Maven team is pleased to announce the release of the Maven
Dependency Plugin, version 2.5.1

The dependency plugin provides the capability to manipulate artifacts.
It can copy and/or unpack artifacts from local or remote repositories
to a specified location.

http://maven.apache.org/plugins/maven-dependency-plugin/

You should specify the version in your project's plugin configuration:

<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-dependency-plugin</artifactId>
<version>2.5.1</version>
</plugin>

Release Notes - Maven 2.x Dependency Plugin - Version 2.5.1

** Bug
  * [MDEP-365] - includes/excludes doesn't work anymore with
unpack-dependencies 2.5

** Improvement
  * [MDEP-368] - Configure plexus-archiver to use java.io.File
methods to set permissions when available.

Have Fun!
--
The Apache Maven team
©2008 java2.5341.com - Jax Systems, LLC, U.S.A.